fatal error: 'itensor/all.h' file not found

Hi all,

I have the following problem with iTensor c++: I followed all the instructions to install iTensor, download and build the libraries. Everything seems to be fine since I run the code; when I run the code (for instance myappname.cc) what I find is:

myappname.cc:1:10: fatal error: ‘itensor/all.h’ file not found

#include “itensor/all.h”


1 error generated.

However, I am almost sure that the libraries are well builded, in the ‘lib’ directory I have the two files ‘libtensor.a’ and ‘libtensor-g.a’.

What I have to do to run the code without problems?

Thanks for the question – are you using the Makefile from the tutorial/project_template folder?

If so, did you customize the LIBRARY_DIR variable at the top of that Makefile?

Dear Miles,

I’ve Just solved the problem. Probably It was stupid, I think It is related to the fact that I put the itensor folder in the desktop. After putting it in the home the problem seems to be solved

Kind regards and Thank you for the answer,


Glad you got it figured out! Yes the folder location has to match the LIBRARY_DIR value in the Makefile.